# File lib/dbi/base_classes/driver.rb, line 12
12:         def initialize(dbi_version)
13:             major, minor = dbi_version.split(".").collect { |x| x.to_i }
14:             dbi_major, dbi_minor = DBI::VERSION.split(".").collect { |x| x.to_i }
15:             unless major == dbi_major and minor == dbi_minor
16:                 raise InterfaceError, "Wrong DBD API version used"
17:             end
18:         end