Module DBI::DBD::SQLite3
In: lib/dbd/SQLite3.rb

DBD::SQLite3 - Database Driver for SQLite versions 3.x

Requires DBI and the ‘sqlite3-ruby’ gem to work.

Only things that extend DBI‘s results are documented.

Methods

Classes and Modules

Class DBI::DBD::SQLite3::Database
Class DBI::DBD::SQLite3::Driver
Class DBI::DBD::SQLite3::Statement

Constants

VERSION = "1.2.3"
DESCRIPTION = "SQLite 3.x DBD for DBI"

Public Class methods

returns ‘SQLite3

See DBI::TypeUtil#convert for more information.

Validates that the SQL has no literal NUL characters. (ASCII 0)

SQLite apparently really hates it when you do that.

It will raise DBI::DatabaseError should it find any.

[Validate]